Attack Prophecy® Installation

Back

All the installation steps should be executed with an account with administration privileges on a CentOS 7 operating system.

  1. Start the configuration script and wait for the operations to be completed:
# ./centos_7_preinstall.sh
  1. Install the provided installation packages:
# yum -y install ./plush-0.2.1-1.el7.x86_64.rpm
# yum -y install ./attackprophecy-LBL-3.1.4-1.el7.x86_64.rpm

Depending on the provided installation packages, version numbers could be different. In this specific case, version number is 3.1.4 for Attack Prophecy and 0.2.1 for the Plush shell.

For both the packages, wait until all the dependencies have been properly configured.

Start the setup utility by typing:

# attackprophecy-setup

TAB and Shift+TAB can be used to move between the available options.

  • Insert the credentials and the parameters for the connections with the LBL database in the HTTP Traffic Source: LBL Load Balancer section;
  • Under Detection modules, select the detection modules which should be enabled;
  • Under the Web Application Firewall: LBL Load Balancer section provide the parameters for configuring the WAF nodes.
  1. Start the Attack Prophecy Services
# systemctl start attackprophecy
  1. The Attack Prophecy Web Interface is now available for the first login via the Web browser.